[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: checkpasswod problem



Wow !
I found problem ;-)
I have install qmail at /var/qmail/new and at patch is =>

+#define auto_qmail "/var/qmail"
+#define config_file "control/sqlserver"

when I modified "/var/qmail" => "/var/qmail/new"
it's work fine but write another error ;-)

Dec  3 15:49:15 temne checkpassword-sql: Received authentication-request for
test
Dec  3 15:49:15 temne checkpassword-sql: Authentication for test failed: no
domain_separator or localpop supplied

what's wrong now ?

Thanks

Brano from Slovakia


----- Original Message -----
From: "[brano]" <brano@xxxxxxxxxxx>
To: <qmail-sql@xxxxxxxxxx>
Cc: "Klemen Vodopivec" <klemen@xxxxxxxxxxx>
Sent: Monday, December 02, 2002 4:42 PM
Subject: Re: checkpasswod problem


> Hmm,
> i run =>
> /usr/local/bin/softlimit -m 2000000
/usr/local/bin/tcpserver-new -dPR -p -u
> qmaild -g qmaild -c50 <IP> smtp /var/qmail/new/bin/qmail-smtpd &
> /usr/local/bin/softlimit -m 2000000 /usr/local/bin/tcpserver-new -dPR -u
> qmaild -g qmaild -c50 <IP> pop3 /var/qmail/new/bin/qmail-popup <NAME>.sk
> /usr/local/bin/checkpassword-sql /var/qmail/new/bin/qmail-pop3d ./Maildir/
&
>
> tail -f /var/log/all.log =>
> Dec  2 16:39:49 temne /kernel: pid 55617 (checkpassword-sq), uid 0: exited
> on signal 11 (core dumped)
> still crahed
> Any ideas ?
> Thanks
>
> Brano from Slovakia
>
>
> > I mean if u have enough memory allocated by tcpserver (if running from
> > tcpserver). This depends on machine hardware...
> >
> > exec /usr/local/bin/softlimit -m 2000000 ...
> >
> > means that 2MB may be allocated by some application. Chech your config.
> >
> > [brano] said:
> > > Hi,
> > > I run qmail at onother IP with the same database user/password and
> > > work's fine (only smtpd patches) and I test patch checkpassword to
check
> > > password from db and not /etc/passwd ;-)
> > > My l/p to access db is correct and tables at db too.
> > > What do you mean memory problem ?
> > >
> > > Thanks
> > > Brano from Slovakia
> > >
> > >
> > >> Had the same problem last week, may be that you have wrong
> > >> username/password in sqlconfig to access to database. Or maybe memory
> > >> problem as read from other mailing lists.
> > >>
> > >> [brano] said:
> > >> > Hi all,
> > >> > I patched checkpassword-0.90 with
> > >> checkpassword-0.90-sql.latest.patch (downloaded 02.12.2002)
> > >> > I run qmail (mysql too)
> > >> > telnet <IP> 110
> > >> > Trying <P>...
> > >> > Connected to <NAME>.
> > >> > Escape character is '^]'.
> > >> > +OK <48938.1038837710@<NAME>.sk>
> > >> > user <USER>
> > >> > +OK
> > >> > pass <PASSWORD>
> > >> > -ERR aack, child crashed
> > >> > Connection closed by foreign host.
> > >> >
> > >> > what's wrong ?
> > >> > Thanks
> > >> > Brano from Slovakia
> > >>
> > >>
> > >> --
> > >> lp, Klemen
> >
> >
> > --
> > lp, Klemen
> >
> >
> >
>
>
>