[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: qmail-smtpd: error while loading shared libraries: libz.so.1



Hi,

I haven't seen this kind of error before. Are you using the qmail-sql
patch only or also additional patches ? Is qmail-smtpd the only part
that doesn't work ? 
Could you verify that no resource-limits are set for qmaild ? Or maybe
you have some (u)limit stuff in the script which starts tcpserver ? 
Since it looks like a memory/resource problem to me.

Regards,
Michael.
On Thu, Oct 17, 2002 at 08:03:20PM +0300, easy wrote:
> 
> 
> 
> Hi there,
> I've setup your qmail-mysql server on Slackware linux, but I have problem with the qmail-smtpd. When I try to connect to 25 port it rejects the connection "Connection closed by foreign host." When I started the qmail-smtpd with strace debuger and when I try to connect the output of was:
> ...
> /var/qmail/bin/qmail-smtpd: error while loading shared libraries: libz.so.1: failed to map segment from shared object: Cannot allocate memory
> 0xbffff89c, [16])             = ? ERESTARTSYS (To be restarted)
> --- SIGCHLD (Child exited) ---
> wait4(-1, [WIFEXITED(s) && WEXITSTATUS(s) == 127], WNOHANG, NULL) = 29508
> write(2, "tcpserver: end 29508 status 3251"..., 34tcpserver: end 29508 status 32512
> ) = 34
> write(2, "tcpserver: status: 0/20\n", 24tcpserver: status: 0/20
> ) = 24
> wait4(-1, 0xbffff588, WNOHANG, NULL)    = -1 ECHILD (No child processes)
> sigreturn()                             = ? (mask now [])
> rt_sigprocmask(SIG_BLOCK, [CHLD], NULL, 8) = 0
> rt_sigprocmask(SIG_UNBLOCK, [CHLD], NULL, 8) = 0
> accept(3,
> 
> I've installed normal qmail but there aren't problems.
> What do you think about it?
> I have 128Mb RAM and 40Mb swap 
> 10Mb free RAM and 38Mb free swap
> 
> Can you give me some advice? Suggestion?
> 
> Thanks in advance.
> Best regards.
> Kiril Tsvetkov, BG