[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Fwd: Re: smtp-auth compile problem...]



On Wed, 2002-09-18 at 00:34, Michael Devogelaere wrote:
 
> > nroff -man mbox.5 > mbox.0
> > nroff -man addresses.5 > addresses.0
> > nroff -man envelopes.5 > envelopes.0
> > nroff -man forgeries.7 > forgeries.0
> > ./install
> > install: fatal: install: usage: install dir
> > make: *** [setup] Error 100
> Because you typed 'make install'. 

Yeah, at first - when I realised I'd done that, I ran 'make setup
check'... When that failed, I tried 'make' (which worked), followed by
'make setup' (which didn't...).

> Could you try this build-sequence:
> make it man
> ./make_owners .
> ./install /var/qmail
> ./make_owners /var/qmail

Okay - at first, ran 'make clean', followed by these instructions, which
failed miserably (it occurs to me now that that's because I hadn't
noticed the period after ./make-install (it's late here, and I could use
more sleep at the *best* of times :-) )).

After that, I unpacked the source tree afresh, and did everything
c-a-r-e-f-u-l-l-y... and have met with success :-)

Just setting up the smtp auth'ing itself now, but it should all be
downhill from here - had simply deleted the /var/qmail/bin directory
before install the new one - nothing wrong with that? It's all running
well - came up straight away...

Thanks heaps for your help - I have a *very* nice little mail system now
(well, as soon as I *see* it requiring credentials to relay anyways...)
- now off to spend my days writing mail admin and user interfaces ;-)

-- 
Cheers,
 Mattt                            icq   : 117539757
 Network and Tech Dood            www   : http://www.pulse.nq4u.net
 mattt@xxxxxxxxxxxxxxxxx          jabber: mattt@xxxxxxxxxxxxxxxxxxxxxxxx
 
     What's got four legs and an arm?  A happy Pit Bull...