[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

daemon dies instantly cont'd



I have attempted to do the exact install that I was trying before on a
clean RH7.2 box and have the same problem - qmail-send refuses to start.
Here's my setup:

PostgreSQL is installed in /usr/local/pgsql


sqtype.h:

/* Uncomment to choose postgresql */
#define SQLTYPE PGSQLTYPE
/* Uncomment to choose mysql */
//#define SQLTYPE MYSQLTYPE

sql.headers:

-I/usr/local/pgsql/include

sql.lib:

-L/usr/local/pgsql/lib -lpq

(not quite sure if there's supposed to be such thing but there's no lpq
file in /usr/local/pgsql/lib)

ls -al /var/qmail/control

total 28
drwxr-xr-x    2 root     qmail        4096 May 25 17:15 .
drwxr-xr-x   11 root     qmail        4096 May 25 15:57 ..
-rw-r--r--    1 root     root            9 May 25 15:54 defaultdomain
-rw-r--r--    1 root     root           18 May 25 15:54 me
-rw-r--r--    1 root     root            9 May 25 15:54 plusdomain
-rw-r--r--    1 root     root           37 May 25 15:54 rcpthosts
-r--r--r--    1 qmails   nofiles       496 May 25 16:19 sqlserver

cat sqlserver

db_use                  yes
query_timeout           5
connection_timeout      5
check_host              yes
autohomedir             no
connectionstring        user=mail password=mail dbname=mail
popconnectionstring     user=mail password=mail dbname=mail
dbtable                 passwd
virt_host_field         virtual_host
login_field             login
uid_field               uid
gid_field               gid
home_field              home
quota_field             hardquota
enabled_field           enabled
startdate_field         startdate
stopdate_field          stopdate
passwd_field            password
lastlogin_field         lastlogin

[root@custmail bin]# ./qmail-getpw alias virtual.org
alias509100/home/mail/virtual.org0

can someone pinpoint my problem?