[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Correct way to HUP?



Hello Jeremy,

HUPing is a correct way to add new local domains to qmail-send. I've tried
it without the control/locals: qmail-sql reads it from the database and that
works fine. But with that file, qmail dumps the errors you reported. I see 
you already found one problem in the code: it stated locals.test in stead of
locals. That was fixed in 0.21 too, but doesn't solve your problem. I'll
look further at this one but for now, i would advise to remove control/locals
or restart qmail-send instead of HUPing.

Kind regards,
Michael Devogelaere.


> A little more info.
> 
> Before HUPing mail will be delivered to all the domains in the locals
> control file.
> 
> After HUPing mail will only be delivered to the one domain in the me control
> file.  All other domains in the locals file get's the error:  
> qmail: 1022010803.257890 delivery 1: deferral: Unable_to_find_alias_user!/
> 
> If I restart qmail completely, those emails who's domains who in the locals
> control will get delivered.
> 
> Is there another method when adding a new local domain to get qmail to
> recognize that domain as a local domain other then HUPing?
> 
> 
> 
> -----Original Message-----
> From: Jeremy Kusnetz 
> Sent: Thursday, May 16, 2002 2:05 PM
> To: 'qmail-sql@xxxxxxxxxx'
> Subject: Correct way to HUP?
> 
> 
> Is there a different way to reHUP qmail-send when making changes to the
> control files?  I've been using .19 since it was first released without any
> problems.  But in the past when making additions to control files I would
> completely restart qmail.
> 
> Yesterday I tried just HUPing the qmail-send process.  Things seemed to be
> okay until a few hours later when i realized qmail was no longer deliverying
> mail, it was just piling up in the queue with a bunch of
> Unable_to_find_alias_user! errors in the log.  I had to do a full restart to
> start delivering mail.  Any ideas?
> 
> I verified that the HUP was the cause by trying again today and watching the
> logs, sure enough no mail was succesfully locally delivered.
> 
> Is the hup somehow making qmail lose connection with it's database?
>